Loading...
Home / SWIG bindings

Home Forums Development SWIG bindings

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6748
    lpujol
    Participant

    Hello,

    I’ve been trying to play with the Python bindings and I am encountering various difficulties.

    1) It seems that the current version of ORE-SWIG uses Quantlib-swiq 1.14, which means (unless i miss something) it cannot be build if I have the latest quantlib-swig bindings (1.16). Quantlib-swig 1.16 is a major change as it uses the native shared pointers. Is there any current work being done to update the shared pointers in ORE-SWIG to be able to work with latest Quantlib version?.

    2) I tried to update the SWIG bindings files moving to the SWIG shared pointers (when needed only) and I’ve been able to remove all the error/warnings when creating the wrap (for QuantExt). (python setup.py wrap). But when I try to build I get many errors which seem to be related to the missing libraries. I noticed that the script is not able to locate “quantext-config”. In fact I couldn`t find it either on github. Is it something availabe or does the user need to adapt the available at QuantLib-Swig?

    Many thanks
    Lluis

    #6772
    Roland Lichters
    Keymaster

    Hi Lluis,

    please try the latest release of ORE and ORE SWIG, both based now on QuantLib/QuantLib-SWIG 1.18.

    Regards,
    Roland

    #6777
    rtruong
    Participant

    Hi,

    First, thank you very much for everyone who contributed and maintained such an impressive code for risk management.

    I am a quant practitioner and have been building models, validating models for at least 15 years. I am currently a consultant in this same area.

    Back to the reason of this posting:
    I tried to build ORE-SWIG (latest GIT master, later than 1.8.5.1) from the latest GIT master and the lastest QuantLib_SWIG(1.19) and QuantLib(1.19). The building process went smoothly for QuantLib 1.19 (from GIT master) and ORE 1.8.5(from zip file) in x64, vs2017, framework 8.1.
    However, ORE-SWIG building was not successfully. I first tried using cmake with ninja. the libpaths that were automatically generated inserted a directory layer of /build/ between ORE and its components. Then, I tried with cmake, followed up with a build with visual studio 2017 where I can input the locations of the libs. No luck either, it failed at the linking.

    I would really appreciate if someone could tested out the building method, presented in the userguide, section 4.4.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.